Paramétrer Wayland et WebRender pour Firefox sur ma distrib


  • Prédateur

    Bonsoir Nal,

    Bon, de temps en temps je regarde où en est ma distrib par rapport aux dernières technos upstream, histoire de vérifier que ça ruisselle bien.

    Pour faire « court », je suis sous Debian Sid GNOME-Wayland.

    Voici les quatres points que je vosu propose :

    • Travailler dans une session Wayland
    • Activer le procédé d’accélération WebRender pour Firefox
    • Passer Firefox en mode Wayland
    • Couper le cordon entre GNOME et X11

    Travailler dans une session Wayland

    Normalement, à partir de Debian 10 Buster, GNOME-Wayland est la session par défaut.

    Pour rappel le choix entre GNOME-Wayland et GNOME-X11 se fait à l’ouverture de la session (par la petite roue crantée à côté du bouton « Se connecter »). Sous une version récente de Debian, choisir « GNOME » revient à choisir GNOME-Wayland (au contraire de « System X11 Default » ou « GNOME sur Xorg »).

    Pour le vérifier, plusieurs méthodes :

    • aller dans « À propos » via les « Paramètres » de GNOME et regarder ce qui est indiqué en face de « Système de fenêtrage »
    • taper dans un terminal $ echo $WAYLAND_DISPLAY et voir si vous obtenez wayland-0
    • tenter la commande restart dans la boite Alt+F2 : ce devrait être refusé.

    Activer le procédé d’accélération WebRender pour Firefox

    Dans la barre d’adresse de Firefox, taper about:config et passer la clé
    gfx.webrender.all sur true si ce n’est pas déjà le cas.

    Sur GNU/Linux l’accélération matérielle étant désactivée par défaut, il peut être nécessaire de passer également la clé layers.acceleration.force-enabled à true pour ne pas bloquer WebRender (pas sûr que ce soit toujours nécessaire).

    Redémarrer le navigateur.

    Pour le vérifier, dans about:support, la ligne « Composition » doit indiquer « WebRender »

    Passer Firefox en mode Wayland

    Par défaut sous Debian Firefox est toujours en mode X11 et se lance donc à travers XWayland.

    Plusieurs avantages accompagnent la version Wayland.

    Deux hypothèses :

    Pour utiliser ponctuellement Firefox en mode Wayland :
    $ MOZ_ENABLE_WAYLAND=1 firefox

    Pour utiliser tout le temps Firefox en mode Wayland :
    Modifier le lanceur /usr/share/applications/firefox.desktop en ajoutant env MOZ_ENABLE_WAYLAND=1 à la ligne Exec=/usr/lib/firefox/firefox %u, comme ceci : Exec=env MOZ_ENABLE_WAYLAND=1 /usr/lib/firefox/firefox %u

    Pour le vérifier :

    • regarder dans about:support où la ligne « Protocole de fenêtrage » devrait indiquer « wayland » au lieu de « x11 ».
    • dans un terminal, taper $ xlsclients : Firefox ne devrait plus figurer dans la liste des applications utilisant XWayland.

    (idem pour Thunderbird : $ MOZ_ENABLE_WAYLAND=1 thunderbird ou modification du lanceur /usr/share/applications/thunderbird.desktop – sauf si vous utilisez la version Flatpak)

    Couper le cordon entre GNOME et X11

    Il s’agit d’une fonctionnalité expérimentale introduite avec GNOME 3.34.

    Après avoir configuré mes lanceurs de Firefox et Thunderbird comme indiqué ci-dessus, voici ce que me renvoie encore la commande $ xlsclients :
    HAL gnome-shell
    HAL ibus-x11
    HAL gsd-xsettings

    Pour que XWayland ne se lance pas inutilement au démarrage, il faut ajouter la clé autostart-xwayland dans org.gnome.mutter experimental-features ce qui peut se faire avec la commande suivante :
    $ gsettings set org.gnome.mutter experimental-features "['autostart-xwayland']"

    Bon, chez moi cela n’a pas marché et $ xlsclients continue de me renvoyer le même résultat.

    Et vous ?

    Télécharger ce contenu au format Epub

    Commentaires : voir le flux atom ouvrir dans le navigateur

    https://linuxfr.org/users/antistress/journaux/parametrer-wayland-et-webrender-pour-firefox-sur-ma-distrib


Log in to reply