Lenovo Ideapad 120s et Debian


  • Prédateur

    Bonjour,

    Je me permets de créer cette discussion suite à l’achat d’un ordinateur portable Lenovo Ideapad 120s-14iap modèle 81A5, sur lequel j’ai essayé d’installer Debian.

    En effet j’ai suivi les étapes mentionnées ci-après et rencontré quelques soucis.

    Les étapes :

    I) J’ai désactivé le démarrage rapide de l’ordinateur.

    II) Ensuite j’ai configuré le BIOS/UEFI comme conseillé sur de nombreux sites :
    - Fn+F2 pour accéder au BIOS
    - Onglet Configuration : USB Legacy : Enabled + Wireless Lan : Enabled
    - Onglet Security : Secure Boot : Disabled
    - Onglet Boot : Boot Mode : Legacy Support + Boot Priority : Legacy First + USB Boot : Enabled + modification de l’ordre de démarrage : USB HDD en première position
    - Onglet Exit : Exit Saving Changes > Yes

    III) J’ai téléchargé l’ISO debian-live-10.1.0-amd64-kde.iso ainsi que Win32DiskImager, et une fois la clé USB bootable créée j’ai redémarré l’ordinateur sur celle-ci.

    IV) Installation de Debian :

    1. Lancement de l’installation + fenêtres “Choix de la langue”, “Choix de la situation géographique”, “Configuration du clavier”, “Chargement des composants”

    2. Arrivé à la fenêtre “Détecter le matériel réseau” j’ai eu le message :

      Certains matériels ont besoin d’un microcode (firmware) non libre pour fonctionner. Ce microcode peut être chargé depuis un support amovible, comme une clé USB ou une disquette.
      Les Fichiers microcode manquants sont : iwlwifi-7265d-22.ucode iwlwifi-7265d-23.ucode iwlwifi-7265d-24.ucode iwlwifi-7265d-25.ucode iwlwifi-7265d-26.ucode iwlwifi-7265d-27.ucode iwlwifi-7265d-28.ucode iwlwifi-7265d-29.ucode
      Si vous possédez un tel support, veuillez le mettre en place maintenant et continuer.
      Faut-il charger le microcode manquant depuis un support amovible ?
      <Oui> <Non>

    3. N’ayant pas les fichiers j’ai cliqué sur <Non>.

    4. Une nouvelle fenêtre “Détecter le matériel réseau” s’affiche, mais cette fois-ci avec une liste de modules parmi lesquels “iwlwifi: Intel® Wireless Wifi driver for Linux”. Lorsque je clic sur cette ligne un écran bleu s’affiche quelques secondes et ensuite je reviens sur la même fenêtre avec la liste de modules.

    5. Alors, j’ai choisi “Aucun dans cette liste” (dernière option dans la liste) qui me renvoie à la fenêtre “Détecter le matériel réseau” qui demande si j’ai les pilotes dans un support amovible. (point 2.)

    6. Je clic à nouveau sur <Non> et cette fois-ci j’ai une fenêtre rouge qui affiche

      "Détecter le matériel réseau,
      Aucune carte Ethernet détectée
      <Revenir en arrière> <Continuer>".

    7. Je clic sur <Continuer>

    8. Cela me renvoie dans la fenêtre “Détecter le matériel réseau” avec la liste (comme au point 4.)… ça commence à devenir répétitif ! O.o

    9. Cette fois-ci je clic sur <Revenir en arrière> qui me renvoie dans le “Menu principal du programme d’installation Debian” sur lequel je choisis “Créer les utilisateurs et choisir les mots de passe”, “Configurer l’horloge”, “Détecter les disques”, “Installation du système”… à chaque fois qu’une étape est franchie l’ordinateur affiche la fenêtre “Détecter le matériel réseau” avec la liste (comme au point 4.) ; et à chaque fois je clic sur <Revenir en arrière>.

    10. Enfin le disque (Carte MMC/SD n°1 (mmcb1k0) - 62.5 GB MMC DF4064) partitionné (méthode de partitionnement “Assisté - utiliser un disque entier” + “Tout dans une seule partition”) j’arrive à la fenêtre “Configuration de paquets”, où (pendant le chargement) une nouvelle fenêtre “Configurer l’outil de gestion de paquets” demande s’il faut utiliser un miroir sur le réseau. Vu que l’ordinateur n’est pas connecté à Internet j’ai choisi <Non>.

    11. Cela fini, j’accepte l’installation du programme de démarrage GRUB sur le disque dur (/dev/mmcblk0 (mmc-DF4064-0x7e810b3e).

    12. Enfin s’affiche la fenêtre “Fin de l’installation”. J’enlève la clé USB de l’ordinateur et je clic sur <Continuer>.

    13. L’ordinateur redémarre. L’écran de connexion s’affiche correctement. Je tape mon login. Démarrage du système en français : OK. Enfin !

    V) Redémarrage de vérification : avant de commencer à chercher une solution pour le Wifi je redémarre afin de m’assurer que tout est OK… Mais après l’écran du GRUB j’ai un écran noir et ceci :

    [ 3.906229 ] i915 0000:00:02.0: firmware: failed to load i915/bxt_dmc_ver1_07.bin (-2)
    [ 3.906229 ] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
    Gave up waiting for root file system device. Common problems:
    - Boot args (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Missing modules (cat /proc/modules; ls /dev)
    ALERT! /dev/mmcblk0p1 does not exist. Dropping to a shell!

    BusyBox v1.30.1 (Debian 1:1.30.1-4) built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.
    (initramfr)_

    VI) Je tape : “help” enter

    (initramfr)help
    Built-in commands:
    . : [ [[ alias bg brack cd chdir command continue echo eval exec
    exit exportfalse fg getopts hash help history jobs kill let
    local printf pwd read readonly return set shift source test times
    trap true type ulimit umask unalias unset wait
    (initramfr)_

    Voila, et je suis coincé là. J’ai peur de faire des bêtises. Je viens donc vers vous car j’aimerais comprendre ce qui s’est passé (et/ou qu’on le découvre ensemble).

    Et en profiter pour vous demander un coup de main (en imaginant que j’arrive à relancer Debian) concernant la configuration du Wifi et les firmwares cités au point 2.

    Je vous remercie d’avance.

    Cordialement.

    martin_g

    Télécharger ce contenu au format Epub

    Commentaires : voir le flux atom ouvrir dans le navigateur

    https://linuxfr.org/forums/linux-debian-ubuntu/posts/lenovo-ideapad-120s-et-debian


Log in to reply